Welcome!


This is a membership forum. As a guest, you can click around a bit. View 5 pages for free. If you would like to participate, please join.

[ Pitmaster Club Information | Join Now | Login | Contact Us ]

There are 4 page views remaining.

Announcement

Collapse
No announcement yet.

PC not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    PC not working

    I am having trouble with my laptop. I am able to sign in, go to recent post. All is good until I click on a post, it starts to open then takes me to the page about this website. I am unable to go anywhere after that. I am posting this on my iPad which seems to be working fine.

    #2
    First guess: you need to clear your browser’s cache

    Have a look at this: https://pitmaster.amazingribs.com/fo...be-misbehaving

    Comment


    • Mt Smoker
      Mt Smoker commented
      Editing a comment
      Thanks for the help but this did not help.

    • raywjohnson
      raywjohnson commented
      Editing a comment
      While on this site. Hit and hold the control key CTRL, then hit the F5 key (for PC/Windows/Linux). Hit and hold the CMD key, then hit R (for Apple/Mac).

      If that does not work, try this: https://www.refreshyourcache.com/en/home/

      If you are windows, you might have to reboot. Sometimes cache gets corrupted over time, a reboot can sometimes fix that.

    • Mt Smoker
      Mt Smoker commented
      Editing a comment
      I thought refreshing cache worked, but started to do the same thing again. I am able to go to the free site with no problems but not able to browse member side. Thanks so much for your help.

    #3
    I had the same issue this morning with Chrome. I tried Firefox in Private mode (no cookies or anything in the cache) and the same thing was happening. Then it went away about an hour ago.

    Comment


    • Mt Smoker
      Mt Smoker commented
      Editing a comment
      I tried edge and have the same problem.

    #4
    I missed this thread and I made another one about this same problem I'm having with Chrome.
    Cleared cache & rebooted PC but Chrome still won't play the game, back to Firefox...sigh..

    Firefox Version 80.0.1 (64bit)
    Chrome Version 85.0.4183.102 (Official Build) (64-bit)


    Grateful for any advise here, thanks in advance

    Comment


      #5
      Just to let everyone know Chrome is still not working for me. I tried Microsoft Edge this morning and everything seems to be working again. Thanks to everyone for the help, you are all the best.

      Comment

    Announcement

    Collapse
    No announcement yet.
    Working...
    X
    false
    0
    Guest
    500
    ["pitmaster-my-membership","login","join-pitmaster","lostpw","reset-password","special-offers","help","nojs","meat-ups","gifts","authaau-alpha","ebooklogin-start","alpha","start"]
    false
    false
    {"count":0,"link":"/forum/announcements/","debug":""}
    Yes
    Rubs Promo
    Meat-Up in Memphis