Welcome!


This is a membership forum. As a guest, you can click around a bit. View 5 pages for free. If you would like to participate, please join.

[ Pitmaster Club Information | Join Now | Login | Contact Us ]

There are 4 page views remaining.

Announcement

Collapse
No announcement yet.

My signature keeps going away

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My signature keeps going away

    It’s happened several times. If I go to my account, it’s there, I edit (not really doing anything), and it shows up while I’m on the site making comments. Next time I sign in, it’s gone. Where, oh where does it go?

    #2
    Must be some kinda sign.

    Comment


      #3
      You need to use indelible ink...

      raywjohnson

      Comment


        #4
        Signatures are globally disabled for display in posts. The real mystery is why you ever see yours at all.

        Comment


        • Soonerpop
          Soonerpop commented
          Editing a comment
          I’m talking about that little pen point thingy that lists your gear, etc. it’s on the post above and others, but just posted elsewhere and no.

        • raywjohnson
          raywjohnson commented
          Editing a comment
          Got it! I did not know this was a thing! The "pen pointy thing" shows the signature text when you hover. Learning is fun.

        #5
        Soonerpop

        I did a check on some of your posts and your signature is on all of them.

        When you sign in, does the pen icon disappear? Or the entire signature text?
        Last edited by raywjohnson; March 8, 2021, 07:36 PM.

        Comment


          #6
          This is one of those things that happens on & off and has for years. Another similar thing is the Like button sometimes goes away. Usually it comes back if you refresh.

          EDIT: In fact right now as I type this, my fountain pen tip (signature icon) is missing, but RayJ's right above me is there.

          Comment


          • Huskee
            Huskee commented
            Editing a comment
            Jerod Broussard You're right, I should edit it down, people don't care about all that since it takes too long to read...

          • raywjohnson
            raywjohnson commented
            Editing a comment
            I will figure out the problem and fix it!

          • Jerod Broussard
            Jerod Broussard commented
            Editing a comment
            Huskee tis a good read....with snazzy links.

          #7
          Originally posted by Soonerpop View Post
          It’s happened several times. If I go to my account, it’s there, I edit (not really doing anything), and it shows up while I’m on the site making comments. Next time I sign in, it’s gone. Where, oh where does it go?
          When you sign in, does the pen icon disappear?

          Or does all the signature text disappear?

          Comment


          • Soonerpop
            Soonerpop commented
            Editing a comment
            The pen icon.

          • raywjohnson
            raywjohnson commented
            Editing a comment
            Are you using a pc (full screen), tablet, or phone?

          • Soonerpop
            Soonerpop commented
            Editing a comment
            Tablet.

          #8
          Tablet. (Ipad)

          Comment


            #9
            raywjohnson Same thing happens for me on a PC. When I first post a reply, the "pen thingy" does not show. When I refresh the page, it shows.

            Kathryn

            Comment


              #10
              Just a test.

              Comment


              • raywjohnson
                raywjohnson commented
                Editing a comment
                Bam! Issue reproduced. Same think happens to me. I can now dig into the code and templates to figure out why this is happening.
                Last edited by raywjohnson; March 11, 2021, 09:59 PM.

              #11
              Alrighty then!

              Code parsed, templates checked, tested, and figured out.

              This is not a bug, it is a "feature". Or at least it is a design flaw.

              When you post to an existing Topic via the form at the bottom, the data is sent and received via an AJAX call. Which is why the page does not refresh when you post. The call is in Javascript code (in the background) and it just updates the page directly (no need to refresh the entire page).

              The code that controls this does not parse the signature and add it to the result. So, the new post does not contain the "parsedSignature" data and it does not display the icon.

              So, that is why you do not see your signature icon when you post, but it shows when you refresh the page (that code does parse the signature and populate the parsedSignature field).

              A poor design in my view as the AJAX call and the regular page refresh code (that renders the post) should be the same code, but the designers of vBulletin apparently do not see it that way.

              Comment


                #12
                Glad you figured it out, raywjohnson . Thanks for getting right on it after Soonerpop mentioned it. Your work here is one of the things that makes The Pit such a great place to visit.

                Kathryn

                Comment


                • Soonerpop
                  Soonerpop commented
                  Editing a comment
                  What she said. 👍🏻

                • Soonerpop
                  Soonerpop commented
                  Editing a comment
                  And yet, I don’t see what AJAX, 🎶 the foaming cleanser 🎵 has to do with any of this. But, thanks.

              Announcement

              Collapse
              No announcement yet.
              Working...
              X
              false
              0
              Guest
              500
              ["pitmaster-my-membership","login","join-pitmaster","lostpw","reset-password","special-offers","help","nojs","meat-ups","gifts","authaau-alpha","ebooklogin-start","alpha","start"]
              false
              false
              {"count":0,"link":"/forum/announcements/","debug":""}
              Yes
              Rubs Promo