Welcome!


This is a membership forum. As a guest, you can click around a bit. View 5 pages for free. If you would like to participate, please join.

[ Pitmaster Club Information | Join Now | Login | Contact Us ]

There are 4 page views remaining.

Announcement

Collapse
No announcement yet.

UltraQ Open Lid Detection

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UltraQ Open Lid Detection

    Hi,

    I have the BBQ Guru UltraQ and have used it many times. However, I don't see that the Open Lid Detection feature actually does anything. As far as I can see, when the UltraQ detects a quick drop in temperature, this should cause the Open Lid Detection feature to kick in and stop the fan. However, when I have this option on or off, it will run the fan at 100% and the result is my heat overruns. FYI, I have the Monolith BBQ Guru Edition Kamado Grill.

    Thanks
    Paul

    #2
    Not familiar with that product. I have a couple Fireboards that have the same feature. Does yours have a place to set how long you want the fan off after lid detection? It's one thing to have it sense a sudden drop, but you need to specify how long you want it to be off.

    Comment


      #3
      - Agree with Rod set it the open detect for an arbitrary time say 5 min and work from there.
      - I have multiple controllers (4 fan based and 1 non fan Smobot) and only I had issue was with my old GuruDX2. Default setting was on and default time was set at 1 min which was way too quick.
      - Shutting off open lid can result in huge temp spikes. Any time you open lid with it off your controller still recognizes temp drop and puts the petal to the metal concerning the fan and it runs while the lid is open stoking the fire.
      - I dont have your controller but I just down loaded your owners manual. In the troublshooting area the 6th symptom discusses what I mentioned above. It also talks about a fan problem that you need to contact BBQ Guru about. In your initial post that may be the issue.
      - You have a darn nice controller there. Hope you get it figured.
      Last edited by tiewunon; January 18, 2021, 08:59 AM.

      Comment


        #4
        Originally posted by tiewunon View Post
        - Agree with Rod set it the open detect for an arbitrary time say 5 min and work from there.
        - I have multiple controllers (4 fan based and 1 non fan Smobot) and only I had issue was with my old GuruDX2. Default setting was on and default time was set at 1 min which was way too quick.
        - Shutting off open lid can result in huge temp spikes. Any time you open lid with it off your controller still recognizes temp drop and puts the petal to the metal concerning the fan and it runs while the lid is open stoking the fire.
        - I dont have your controller but I just down loaded your owners manual. In the troublshooting area the 6th symptom discusses what I mentioned above. It also talks about a fan problem that you need to contact BBQ Guru about. In your initial post that may be the issue.
        - You have a darn nice controller there. Hope you get it figured.
        Super. Thanks Tiewunon and Rod. I'm not able to see anywhere to set the open detect time and not sure if this can be controlled with the UltraQ. I'll do a bit more scientific testing with some boiling water to raise and then lower the temp to see if there really is a behavior difference when take the probe out of the boiling water and see if the fan keeps running.

        Comment


          #5
          Originally posted by tiewunon View Post
          - Agree with Rod set it the open detect for an arbitrary time say 5 min and work from there.
          - I have multiple controllers (4 fan based and 1 non fan Smobot) and only I had issue was with my old GuruDX2. Default setting was on and default time was set at 1 min which was way too quick.
          - Shutting off open lid can result in huge temp spikes. Any time you open lid with it off your controller still recognizes temp drop and puts the petal to the metal concerning the fan and it runs while the lid is open stoking the fire.
          - I dont have your controller but I just down loaded your owners manual. In the troublshooting area the 6th symptom discusses what I mentioned above. It also talks about a fan problem that you need to contact BBQ Guru about. In your initial post that may be the issue.
          - You have a darn nice controller there. Hope you get it figured.
          Tiewunon, so I did a bit more of a scientific test. Indeed, the open lid detection does actually work. I had a cup of boiled water which was at around 170f. I put the put probe in there and set the target temp of the put to be 150f. When I removed the pit probe from the water it went down quickly and I timed how long the fan stayed at 0% and it was pretty much exactly 2 minutes, so at least I know it works. This is a bit short to do some work with the lid open and then close it and wait until the temp stabilizes. As you say 5 minutes would be a better time.

          I'll email BBQ Guru support to see if there's any way to change the time from 2 minutes.......

          Thanks again for the quick help.

          Comment


            #6
            Monopauly be sure to mention all your symptoms. In that area I mentioned in your owners manual they mention potential bad relays in fan or controller. My nephew has been treated like gold when he has spoke to tech support. Gals name was Lisa Jo or something.
            - I have my flameboss set at 7min. For some reason that controller likes to give me runaway fires with the Primo.
            - Both my Fireboards 1 & 2 I have the OL at 5 mins and have the respective fans throttled down to 20 & 30%.
            Like I said you have a great controller. It is most likely something simple.
            - Good luck and keep the fires burning.

            Comment


            • Monopauly
              Monopauly commented
              Editing a comment
              Super - Thanks Tiewunon.

          Announcement

          Collapse
          No announcement yet.
          Working...
          X
          false
          0
          Guest
          500
          ["pitmaster-my-membership","login","join-pitmaster","lostpw","reset-password","special-offers","help","nojs","meat-ups","gifts","authaau-alpha","ebooklogin-start","alpha","start"]
          false
          false
          {"count":0,"link":"/forum/announcements/","debug":""}
          Yes
          Rubs Promo