Welcome!


This is a membership forum. As a guest, you can click around a bit. View 5 pages for free. If you would like to participate, please join.

[ Pitmaster Club Information | Join Now | Login | Contact Us ]

There are 4 page views remaining.

Announcement

Collapse
No announcement yet.

Excitement and questions: Fireboard + Pit Viper + 26" Weber

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Excitement and questions: Fireboard + Pit Viper + 26" Weber

    With most of my economic relief money already allocated to more responsible pursuits, I decided to treat myself to a fireboard and pit viper setup. I received the fireboard today, so I went down to Home Depot and got a step bit. I drilled my 1" hole using some clipper blade lubricant that came with my beard grooming kit. I figured it wouldn't hurt. I don't know if it helped but bit popped right through the metal with no smoke. And now!... I wait for my pit viper and adaptor to arrive on Monday

    Sadly, I discovered that my kettle took some cosmetic damage in the move from Arizona but I'm going to make things right by enhancing it, touching it up with some black high-temp paint (recommendations?) and using it a whole lot more.

    A question: I read a thread about decreasing the fan pause from 7 minutes to 1 minute in the lid-off feature settings so I changed that already. What about this maximum fan power setting? What does it do? Does it have an effect on overshoot of the setpoint temp?

    #2
    Rustoleum high temp is pretty good; usually I've found the "satin" finishes at my local Home Despots and Lowes, which would stand out crom the high gloss enamel Weber uses.

    I think Rustoleum does make a high gloss too, but you'd most likely have to special order that in.
    Last edited by Loren; April 30, 2020, 05:51 PM.

    Comment


    • Loren
      Loren commented
      Editing a comment
      PS do you have the Slow'n''Sear for the 26" too?

    • jhapka
      jhapka commented
      Editing a comment
      Thanks for the tip I'll look into that. That's a whole ordeal. I ordered the SnS XL from Great Britain when ABC was singing the "there's not enough customer demand so we discontinued the XL" tune. Now I see they're back in stock on ABCs site. At the end of the day I'm happy that they have continued producing it, so I'm not salty.

    #3
    Sounds awesome. Tricking out my 26 is on my list of quarantine projects I intend to accomplish. Looks like rain this weekend. Maybe that means I'll get to it then.

    Comment


    • jhapka
      jhapka commented
      Editing a comment
      What's your plan?

    • Attjack
      Attjack commented
      Editing a comment
      jhapka I'm going to drill and install the port for the fan, drill and a probe port, then drill and install an auxiliary handle on the front of the lid for easy opening and closing. So mostly lots of drilling followed by some installing.

    #4
    On smaller grills like the pk original I sometimes set the max fan to 50 or 75%, but for that kettle I’d just leave it at 100. It won’t overshoot too much as there is a lot of room in the 26.

    Comment


      #5
      Great first cook tonight with some chicken. I didn't have time or meat to cook low and slow so I just putzed around by trying to set it to 225 and hold then bump it up to do a chicken at 325. The temp hit 225 really quickly after starting 12 coals and dumping in the slow and sear. But then it just kept rising... so I reset the setpoint to 250. Then it just cruised past 250. I checked the lid to make sure it wasn't leaking and I checked the lower vents to make sure they were completely closed up. BONEHEAD MOVE, I failed to realize that the pit viper has a damper control! So I closed the pit viper damper to half and changed the setpoint to 325. There was a little firmware issue where the fan was engaging at 327 for a bit but turning the fan off and on again fixed it and it held at 325-330 for the duration of the cook. I'm about to take the chicken off and I'm sure it will be delicious.

      Comment


        #6
        Let me ask a dumb question, where your bottom vents closed? If you had run away temps like that it sounds like you had air leakage for sure. I’ve run a Pit Viper fan with my FireBoard on my 22 and 26 for a couple of years now and have had zero problems with temps. I have never necked down the damper, I run full open. Be sure you’re completely closed off on the bottom and only adjust the top to about halfway and let it run. If too low open the top a little, conversely if too strong close it down some. Don’t over think what, when you dial it in, is set and forget magic !!

        Comment


          #7
          Bottom vents should be fully closed, fan damper should be wide open, upper vent about 1/4-1/2 of the way open. The only intake needs to be the fan, the upper vent I usually set to 1/3 for 225F and maybe 1/2 for 350.

          Where was your pit probe located?

          Only other thing I can think of is that there is a leak between the lid and base, which can be fixed with either a stick on gasket, bending the lid back to round, or both.

          Comment


            #8
            First thing I did was double check the bottom vents and they were closed. I installed a gasket around my lid before the first use. Didn’t see any smoke sneaking out around the rim. Pit probe was in the middle of the grate. Top vent was 1/2 closed.
            Polarbear777 Troutman
            Last edited by jhapka; May 5, 2020, 10:29 AM.

            Comment


              #9
              Where is the fan in relation to the SnS? I run mine so the fan input is opposite the SnS. Lid vents are on the same side as the fan.

              Comment


              • jhapka
                jhapka commented
                Editing a comment
                jlazar I put the fan between the fins and grate opposite the SnS. Top vents opposite the SnS above the meat and probe.
                Last edited by jhapka; May 5, 2020, 01:21 PM.

              #10
              Update: After I got home from work today I gave everything a once-over. I had tunnel vision when drilling the fan port hole, so I missed that one of my ash sweeper fins was slightly bent upward and not making consistent contact with the bottom of the inside of the kettle. I don't want to point fingers, but my dad was storing it for me and spontaneously volunteered to pressure wash the inside of the kettle before I picked it back up. I took the whole one-touch whatever system off and with some bending and hammering think I have all the fins making solid contact with the floor now. They make a stronger scraping sound anyway. Hopefully this was the source of my extraneous air intake.

              Comment


                #11
                This seems more like what I should be getting.
                Attached Files

                Comment


                  #12
                  Looks like you found the culprit. Should be smooth sailing from here on out, jhapka .

                  Kathryn

                  Comment


                    #13
                    I don't mean to hijack your thread. If I should start my own thread please let me know.

                    I had some issues with temperature control too and had a difficult time figuring it out. I used a Fireboard on a new 22" Weber with a Pit Viper Fan set up. Reading through the posts here I think my top vent could have been the issue now, as I was running it fully open. Here is a screenshot of the cook graph. As you can see there are a lot of temperature variations. The meat came out nice in the end but I felt like I had to do more babysitting than normal.

                    I set the temperature to 250° and it shot up very quickly, from there it came down, but mostly ran high. Does fully opening the top vents cause these types of problems? I was expecting more consistency but my lack of experience gave me some mixed results. The larger spikes are when I had to make clear the charcoal out of the SnS and refuel.

                    Click image for larger version  Name:	Screen Shot 2020-06-14 at 8.42.37 PM.png Views:	0 Size:	75.7 KB ID:	862303
                    Last edited by 1bottlerocket; June 14, 2020, 01:04 PM.

                    Comment


                    • jhapka
                      jhapka commented
                      Editing a comment
                      1bottlerocket Do you have the graph that shows setpoint and fan activity?

                    • jhapka
                      jhapka commented
                      Editing a comment
                      1bottlerocket I think you’re on the right track. Make sure the ash sweeper fins are making solid contact with the bottom of the kettle and fully closed. I know the typical rule is don’t close the top vent to less than half but that’s with passive airflow. With the pit viper pumping air in actively there’s plenty of exhaust and more control of passive airflow at 1/3 open in my experience.

                    #14
                    Unfortunately, I do not have that graph that shows the fan activity and set point. I was still figuring things out at the time and for whatever reason, I did not think to get that info. The test run with no food went so smoothly I could not believe how steady it was.

                    This was my test run graph:

                    Click image for larger version

Name:	Screen Shot 2020-06-15 at 10.07.56 PM.png
Views:	168
Size:	49.1 KB
ID:	863224

                    The set point was 250 and it pretty much held for 2.5 hours in light rain and wind.

                    I then cooked a pork butt as a warm-up and that's when I began getting the wild swings. I later figured out that I plugged into the 12v port and not the fan port, which is why the fan was just constantly running.

                    After that, I figured out the wiring but the temperature still ran higher than expected. I am going to try and adjust the lid-off feature and run the top vents at 1/2-1/3 next time to see if that helps.

                    In the notes, I thought perhaps I started with too many lit briquettes.
                    Last edited by 1bottlerocket; June 15, 2020, 02:10 PM.

                    Comment


                    • jhapka
                      jhapka commented
                      Editing a comment
                      1bottlerocket I think you'll have your problem solved if you do everything you mentioned here

                    • 1bottlerocket
                      1bottlerocket commented
                      Editing a comment
                      Thanks for posting this, it really helped.

                  Announcement

                  Collapse
                  No announcement yet.
                  Working...
                  X
                  false
                  0
                  Guest
                  500
                  ["pitmaster-my-membership","login","join-pitmaster","lostpw","reset-password","special-offers","help","nojs","meat-ups","gifts","authaau-alpha","ebooklogin-start","alpha","start"]
                  false
                  false
                  {"count":0,"link":"/forum/announcements/","debug":""}
                  Yes
                  Rubs Promo
                  Meat-Up in Memphis